Commit 36d59542 authored by Gradl, Tobias's avatar Gradl, Tobias
Browse files

15: de-boot core library

Task-Url: #15
parent 0aac4b17
Pipeline #17807 passed with stage
in 2 minutes and 6 seconds
......@@ -19,8 +19,8 @@ allprojects {
webmvcPac4jVersion = "4.0.1"
pac4jVersion = "4.1.0"
lombokVersion = "1.18.14"
springVersion = "5.2.9.RELEASE"
servletApiVersion = "4.0.1"
jspApiVersion = "2.3.3"
librarySets = [
commonTest: [
......
plugins {
id 'java-library'
id 'java-library'
}
description = 'dariahsp - core library'
......@@ -10,8 +10,7 @@ dependencies {
api "org.pac4j:spring-webmvc-pac4j:$webmvcPac4jVersion"
api "org.pac4j:pac4j-saml:$pac4jVersion"
api "org.pac4j:pac4j-http:$pac4jVersion"
//implementation 'org.springframework.boot:spring-boot-starter-web'
implementation "org.springframework:spring-webmvc:$springVersion"
implementation "org.springframework:spring-webmvc"
implementation "javax.servlet:javax.servlet-api:$servletApiVersion"
compileOnly "org.projectlombok:lombok:$lombokVersion"
......
......@@ -3,10 +3,6 @@ plugins {
id 'org.springframework.boot' version "2.3.4.RELEASE"
}
ext {
jspApiVersion = "2.3.3"
}
dependencies {
implementation project(':dariahsp-core')
implementation 'org.springframework.boot:spring-boot-starter-web'
......
......@@ -4,7 +4,6 @@ plugins {
ext {
tilesVersion = "3.0.8"
jspApiVersion = "2.3.3"
jstlVersion = "1.2"
}
......@@ -13,9 +12,13 @@ dependencies {
//implementation "org.apache.tiles:tiles-core:$tilesVersion"
//implementation "org.apache.tiles:tiles-jsp:$tilesVersion"
//implementation "org.apache.tiles:tiles-api:$tilesVersion"
implementation "org.springframework:spring-webmvc"
implementation "javax.servlet:jstl:$jstlVersion"
providedCompile "javax.servlet:javax.servlet-api:$servletApiVersion"
providedCompile "javax.servlet.jsp:javax.servlet.jsp-api:$jspApiVersion"
/*implementation "javax.servlet:jstl:$jstlVersion"
providedCompile "javax.servlet:javax.servlet-api:$servletApiVersion"
providedCompile "javax.servlet.jsp:javax.servlet.jsp-api:$jspApiVersion"
/*compile 'de.unibamberg.minf.core:core-web:5.1.2-RELEASE'
compile 'org.springframework:spring-context:4.3.6.RELEASE'
compile 'org.springframework:spring-core:4.3.6.RELEASE'
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment